websocketpp
C++ library implementing the WebSocket protocol
WebSocket++ is a C++ library that can be used to implement WebSocket functionality. The goals of the project are to provide a WebSocket implementation that is simple, portable, flexible, lightweight, low level, and high performance.
- Versions: 0.8.2
- Website: https://www.zaphoyd.com/websocketpp/
- Licenses: Modified BSD
- Package source: gnu/packages/web.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of websocketpp
as follows:
guix install websocketpp
Or install a particular version:
guix install websocketpp@0.8.2
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of websocketpp about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/websocketpp'><img src='https://packages.guix.gnu.org/packages/websocketpp/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/websocketpp)
Example Org:
[[https://packages.guix.gnu.org/packages/websocketpp][https://packages.guix.gnu.org/packages/websocketpp/badges/latest-version.svg]]