clang
C language family frontend for LLVM
Clang is a compiler front end for the C, C++, Objective-C and Objective-C++ programming languages. It uses LLVM as its back end. The Clang project includes the Clang front end, the Clang static analyzer, and several code analysis tools.
- Versions: 9.0.1 · 8.0.1 · 7.1.0 · 6.0.1 · 3.9.1 · 3.8.1 · 3.7.1 · 3.5.2 · 19.1.4 · 18.1.8 · 17.0.6 · 16.0.6 · 15.0.7 · 14.0.6 · 13.0.1 · 12.0.1 · 11.1.0 · 10.0.1
- Website: https://clang.llvm.org
- Licenses: ASL 2.0
- Package source: gnu/packages/llvm.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of clang
as follows:
guix install clang
Or install a particular version:
guix install clang@10.0.1
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
HTML: <a href='http://127.0.0.1:3000/packages/clang/'><img src='http://127.0.0.1:3000/packages/clang/badges/latest-version.svg'></img></a> Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/clang/badges/latest-version.svg)](http://127.0.0.1:3000/packages/clang/) Org: [[http://127.0.0.1:3000/packages/clang/][http://127.0.0.1:3000/packages/clang/badges/latest-version.svg]]