This package browser is in early development. Mind the rough edges.

clang

C language family frontend for LLVM

Clang is a compiler front end for the C, C++, Objective-C and Objective-C++ programming languages. It uses LLVM as its back end. The Clang project includes the Clang front end, the Clang static analyzer, and several code analysis tools.

Installation

Install the latest version of clang as follows:

guix install clang

Or install a particular version:

guix install clang@10.0.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.