clojure-core-async
Facilities for async programming and communication in Clojure
The core.async library adds support for asynchronous programming using channels to Clojure. It provides facilities for independent threads of activity, communicating via queue-like channels inspired by Hoare’s work on Communicating Sequential Processes (CSP).
- Versions: 1.6.681
- Website: https://github.com/clojure/core.async
- Licenses: EPL 1.0
- Package source: gnu/packages/clojure.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of clojure-core-async
as follows:
guix install clojure-core-async
Or install a particular version:
guix install clojure-core-async@1.6.681
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of clojure-core-async about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/clojure-core-async'><img src='https://packages.guix.gnu.org/packages/clojure-core-async/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[![Version in GNU Guix](https://packages.guix.gnu.org/packages/clojure-core-async/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/clojure-core-async)
Example Org:
[[https://packages.guix.gnu.org/packages/clojure-core-async][https://packages.guix.gnu.org/packages/clojure-core-async/badges/latest-version.svg]]