This package browser is in early development. Mind the rough edges.

eigen

C++ template library for linear algebra

Eigen is a C++ template library for linear algebra: matrices, vectors, numerical solvers, and related algorithms. It provides an elegant API based on "expression templates". It is versatile: it supports all matrix sizes, all standard numeric types, various matrix decompositions and geometry features, and more.

Installation

Install the latest version of eigen as follows:

guix install eigen

Or install a particular version:

guix install eigen@3.4.0

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of eigen about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/eigen'><img src='https://packages.guix.gnu.org/packages/eigen/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/eigen/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/eigen)

Example Org:

[[https://packages.guix.gnu.org/packages/eigen][https://packages.guix.gnu.org/packages/eigen/badges/latest-version.svg]]