liquidprompt
Full-featured prompt for Bash & Zsh
Liquidprompt is an adaptive prompt for Bash and Zsh that gives you a nicely displayed prompt with useful information when you need it. It does this with a powerful theming engine and a large array of data sources.
In order to use liquidprompt with Zsh, you should use the following snippet with Guix Home:
(service home-zsh-service-type (home-zsh-configuration (zshrc (list ;;... ;; This loads liquidprompt (mixed-text-file "liquidprompt" "[[ $- = *i* ]] && source " liquidprompt "/share/liquidprompt/liquidprompt") ;; This loads the powerline theme available in liquidprompt (mixed-text-file "powerline-theme" "source " liquidprompt "/share/liquidprompt/themes/powerline/powerline.theme"))))))
- Versions: 2.1.2
- Website: https://github.com/liquidprompt/liquidprompt
- Licenses: AGPL 3+
- Package source: gnu/packages/shellutils.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of liquidprompt
as follows:
guix install liquidprompt
Or install a particular version:
guix install liquidprompt@2.1.2
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of liquidprompt about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/liquidprompt'><img src='https://packages.guix.gnu.org/packages/liquidprompt/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/liquidprompt)
Example Org:
[[https://packages.guix.gnu.org/packages/liquidprompt][https://packages.guix.gnu.org/packages/liquidprompt/badges/latest-version.svg]]