This package browser is in early development. Mind the rough edges.

llvm

Optimizing compiler infrastructure

LLVM is a compiler infrastructure designed for compile-time, link-time, runtime, and idle-time optimization of programs from arbitrary programming languages. It currently supports compilation of C and C++ programs, using front-ends derived from GCC 4.0.1. A new front-end for the C family of languages is in development. The compiler infrastructure includes mirror sets of programming tools as well as libraries with equivalent functionality.

Installation

Install the latest version of llvm as follows:

guix install llvm

Or install a particular version:

guix install llvm@10.0.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

HTML: <a href='http://127.0.0.1:3000/packages/llvm/'><img src='http://127.0.0.1:3000/packages/llvm/badges/latest-version.svg'></img></a>
Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/llvm/badges/latest-version.svg)](http://127.0.0.1:3000/packages/llvm/)
Org: [[http://127.0.0.1:3000/packages/llvm/][http://127.0.0.1:3000/packages/llvm/badges/latest-version.svg]]